最新消息:欢迎访问Android开发中文站!商务联系微信:loading_in

AndroidStudio的Gradle插件版本更新简介

新手入门 AndroidChina 5103浏览 0评论

Android构建系统使用Android的Gradle插件通过Gradle的构建工具来支持构建Android程序。Android的Gradle插件独立于AndroidStudio运行,所以该插件和Gradle构建系统需要独立更新。

更新Android的Gradle插件

自动更新
当你更新完Android Studio,你可能收到自动更新最新版插件的弹窗通知。你可以选择接受更新,或者自己根据项目需求指定插件版本

2352140-befa460a1e9330c1

指定更新
通过修改项目目录最顶部的build.gradle文件指定Gradle插件

buildscript {
  ...
  dependencies {
    classpath 'com.android.tools.build:gradle:2.2.0'
  }
}

注意 最好不要动态设置插件的版本号。例如:com.android.tools.build:gradle:2.+ 使用这种方式可能会导致版本更新的混乱。

如果指定的插件版本还没有下载,Gradle会在你下次构建项目的时候下载,你也可以通过点击Tools > Android > Sync Project with Gradle Files来手动下载。

更新Gradle

自动更新
当你更新完Android Studio,你可能收到自动更新最新版Gralde的弹窗通知。你可以选择接受更新,或者自己根据项目需求指定Gradle版本

2352140-befa460a1e9330c1

指定更新
通过修改Gradle的分配引用文件gradle/wrapper/gradle-wrapper.properties指定Gradle版本,其实是修改了Gradle的下载链接,需要翻墙。也可以通过这里选择Gradle的版本下载,再复制到电脑的Gradle目录下。

  1. Mac上会默认下载到/Users/<用户名>/.gradle/wrapper/dists
  2. Windows默认下载到C:/Users//.gradlewrapper/dists
distributionUrl = https\://services.gradle.org/distributions/gradle-2.10-all.zip

通过Project Structure修改

也可以通过File > Project Structure > Project来修改修改Gradle版本Gradle version和插件版本Andtoid Plugin Version

2352140-5def4e05f9e5ebcc

PS: 使用中发现AndroidStudio应该有支持最高版本的Gradle限制,例如:在Android Studio 2.0上使用Gradle2.10是不起作用的,后来更新了AS问题解决了。

原文地址

文/violinlin(简书作者)
原文链接:http://www.jianshu.com/p/ac9e3d664378
著作权归作者所有,转载请联系作者获得授权,并标注“简书作者”。

转载请注明:Android开发中文站 » AndroidStudio的Gradle插件版本更新简介

您必须 登录 才能发表评论!